Newest yum Questions

Q&A for system and network administrators

Yum offline installation on rhel7.2 failed

I am trying to deploy my java server application on a client machine running Red Hat Linux 7.2 with no internet connection. I managed to do it on my own test server in azure, several times, but the ...

why yum could not find the python-pip packages on some PCs

I got a very strange problem and cannot figure out why. When I run yum info python-pip command on some CentOS 7 machines, it returns Error: No matching Packages to list. But, I used to install python-...

redhat 6 | how-to install libpcap-devel

the server is running: # cat /proc/version Linux version 2.6.32-431.el6.x86_64 (mockbuild@x86-023.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-4) (GCC) ) #1 SMP Sun Nov 10 22:...

CentOS 7.2 andhivex

I need to install libguestfs on a CentOS/RHEL 7.2 server, and I ran into a snag in the dependency chain. When I try to yum localinstall hivex-1.3.10-5.7.el7.x86_64.rpm, it finds a dependency on "perl(...

installing gtk-sharp2 on Centos7

I'm trying to instal (on centOS 7) this package but I got this error below ( I admit that I'm a novice with yum as well): sudo yum install gtk-sharp2 Loaded plugins: fastestmirror, langpacks, ...

Installing Postgres server 9.6 on Amazon Linux

What's the best way to install postgres-server 9.6 on Amazon Linux without building from source? I tried running rpm -i https://download.postgresql.org/pub/repos/yum/9.6/redhat/rhel-6-x86_64/pgdg-...

How to install gdk-pixbuf-devel on Amazon Linux?

I'm trying to install gdk-pixbuf-devel on Amazon Linux so I can use pixbuf with cairocffi in python. I found an RPM located here: https://rpmfind.net/linux/RPM/opensuse/12.2/x86_64/gdk-pixbuf-devel-2....

CentOS 7 MariaDB Error “Failed to start mariadb.service: Unit not found.” [closed]

I am somewhat new to Linux, testing various LAMP setups in Virtualbox on Windows. Currently I have a Centos 7 VM that I am trying to install MariaDB on. I am following instructions here: http://www....

Installing sysbench on redhat 7 - 404 not found

I have redhat 7 and I've been trying to get sysbench installed and following the instructions here: https://wiki.mikejung.biz/Sysbench#Installing_Sysbench yum install http://www.percona.com/...

Yum cannot update - there are conflicts

What the problem is To put it in short this is what give me the head ache: --> Finished Dependency Resolution Error: Package: policycoreutils-2.5-11.el7_3.x86_64 (base) Requires: ...

Adding CentOS 6.8 Client to Spacewalk

I'm trying to add a CentOS 6.8 client to Spacewalk 2.6 to I can push out updates. In order to add the client I need to first install some packages: rhn-client-tools rhn-check rhn-setup rhnsd m2crypto ...

Yum update failing because of coreutils issue [duplicate]

Im attempting to yum update but it is failing on: Error: Package: coreutils-libs-8.4-37.el6_7.3.x86_64 (@updates) Requires: coreutils = 8.4-37.el6_7.3 Removing: coreutils-8.4-37....

Files in /etc/yum.repo.d don't seem to be read

I have the following my /etc/yum.repo.d directory: [fixnetix-base] name=Fixnetix Base baseurl=http://10.20.82.149/os/rhel/x86_64/6.8 gpgcheck=0 enabled=1 [fixnetix-security] name=Fixnetix Security ...

yum Could not retrieve mirrorlist

# yum clean all Failed to set locale, defaulting to C Cleaning repos: base extras updates Cleaning up Everything yum info got a timeout: # yum --verbose info Failed to set locale, defaulting to C ...

How to bypass this Transaction check error

I have this error when I use yum update Transaction check error: file /usr/lib/node_modules/npm/node_modules/node-gyp from install of npm-1:3.1 0.3-107.el7.x86_64 conflicts with file from ...

Yum wants to remove and re-install my kernel. Is this safe?

I am running CentOS 7 and I just ran yum update. Something in the resulting output makes me hesitate to type y to proceed with the update. Here's what it says: ======================================...

Install RRDtool 1.4.7 on CentOS 6

I'm trying to install Zenoss core 4.2.3 which requires RRDtool 1.4.7. CentOS 6 comes with RRDtool 1.3.8 So, I've downloaded the RPM rrdtool-1.4.7-1.el6.rfx.x86_64.rpm and tried to install it, which ...

Yum/Apt Package Repository Managament, Mirrors and Hosted, Must be something better

I've been managing my Yum repositories with Pulp, mirrored and hosted. The complexity is pretty serious, so I've only considered the operational and infrastructure related repositories. DevOps has ...

Package management and building old software

At work we have a vendor supplied library that was delivered to us in the form of C++ headers and .so files. Our production environment has been CentOS 6 for a long time, but we may soon upgrade to ...

How to reinstall or downgrade PHP on Centos

Having used the atomic repository for a couple of years to update my Centos (6.8) and Plesk 12, I required an update to PHP that wasn't yet available. I added the remi repos and updated PHP to 5.5.38 ...

yum having conflicts while attempting to install php-xml

Using CentOS Linux release 7.2.1511 (Core) and running PHP 5.5.38 (cli) (built: Jul 21 2016 12:25:20). Attempting to install php-xml but am receiving the following issue: sudo yum install php-xml ...

How to map PHP module name with corresponding rpm package name on Centos?

I'm often provided a list of PHP modules as requirements for a given web application I need to setup on a server, and I find it sometimes tedious to find the corresponding RPM package name that I need ...

uninstalled cracklib-dicts, sudo gone, how to recover

I was trying to install the packer utility to build AWS AMI's. However it was conflicting with a builtin utility of the same name, which is part of the cracklib-dicts package. I used yum to remove ...

Centos - How to avoid bugged yum updates

I'm running a Centos server, and i've had issue with bugged yum updates. Currently i have a cron job, which does a yum update every 3 months, but sometimes i get an update with a bug in it, that ...

microcode.service fails to load where to find rpm microcode_ctl-2.1-16.3.el7_3?

in redhat bugzilla 1412187 microcode.service fails to load due to broken it say's: Verified as fixed in microcode_ctl-2.1-16.3.el7_3 I cannot find where do download this updated rpm from? I can't ...

Can I specify the install root with yumdb on the command line?

rpm has a command-line option --root to specify another install root than /. yum has a command-line option --installroot for this. They are useful for maintaining chroot environments so that these ...

force downgrade on the next `yum update`

I have microcode_ctl-2.1-16.1.el7_3.x86_64 I have control of the centos repo I want the next yum update which runs on any machine to automatically downgrade this package to microcode_ctl-2.1-16.el7....

How could a CentOS 7.2 system return a response to $ yum list, but not to yum install?

I found a system with a peculiar problem. It has no repositories enabled, but still responds to $ yum search. I've asked around, and read a good bit of the documentation (e.g. https://www.ibm.com/...

Outward internet access behind a load balancer

I am experimenting with putting our AWS EC2 instances behind a load balancer. This works well but I have an issue that I am unsure how to resolve. The instances that are behind the load balancer don'...

How to find out yum package names

Recently I needed to install yum mbstring but because I have two different versions of PHP installed I needed to install mbstring for php 5.5. Through some random google searches I figured out to run: ...

CentOS 6 local update repository and security updates

I know that official CentOS 6 (even 7) update repositories does not provide security information. The consequence is thatyum-plugin-security plugin and yum check-update --security command does not ...

yum security plugin questions

When i run "yum updateinfo list available", many packages are listed [apcon@localhost ~]$ sudo yum updateinfo list security all Loaded plugins: fastestmirror i FEDORA-EPEL-2014-4045 security ...

redhat 6 | glibc install issue [libtool]

Could you please advise on how to resolve the following: I would like to install libtool but it complains about glibc as this is a very critical library for the system, How it could be solved ? # ...

how to “--setopt=protected_multilib=false -y” without yum install

We have a client who needs an installation on a VM with no connection to the internet. Usually I would've used a chef client who will preform command lines such as: yum install glibc.i686 --setopt=...

How to downgrade mongodb 3.4.2 to 2.6.11?

I had mongodb 2.6.11 installed on my CentOS sandbox server. Dec 03 22:24:38 Updated: mongodb-org-mongos-2.6.11-1.x86_64 Dec 03 22:25:07 Updated: mongodb-org-tools-2.6.11-1.x86_64 Dec 03 22:25:08 ...

Difference between rpm -ivh <package> and yum install <package>

Supposing that I am going to install a package, what's the difference between these two commands: rpm -ivh <package> and yum install <package> same question for example with rpm -Uvh <...

Yum generates error message: AttributeError: 'module' object has no attribute 'RhnServerException'

Linux version: # cat /etc/redhat-release Red Hat Enterprise Linux Server release 5.8 (Tikanga) # cat /etc/issue.net Oracle Linux Server release 5.8 When running yum, it generates the following error ...

Install Go 1.8 with yum

I'm new to Linux / Yum and just set up an AWS AMI instance. I'm trying to install Go 1.8. When I ran sudo yum install golang it installed version 1.6.3. How can I make it install version 1.8? [ec2-...

Yum upgrade php error how to read

I am trying to upgrade php from 5.3 to 5.6 on centos 6.8. I am using Remi repo and have followed the instructions there. However on running: yum upgrade "php*" i get the errors here http://...

Cannot remove Pulp tasks after unregistering consumer

I am having an issue deleting some tasks in Pulp. After decommissioning a consumer, it has become impossible to remove the hanging tasks related to it. Listing the tasks shows entries related to ...

How to fix dependency issue with partially completed yum update of glibc

I attempted to update my production web server this morning (t2 running Amazon Linux) but it failed because I ran out of RAM (php-fpm had it all). I stopped php-fpm to free up some RAM, but the yum ...

Cannot retrieve repository from channel “rhel-x86_64-server-6”

I have a red hat satellite 5.7 with subscribed servers to the rhn under a 3.4 rhev installation and I just created a VM with RHEL 6.6, subscribed it with satellite to the rhn, configured the channels ...

Install PHP 5.6 on CentOS 7 - No package php56 available - yum misconfiguration?

I'm trying to install PHP 5.6.x on my CentOS 7.2.1511 installation. I've followed this guide: https://webtatic.com/packages/php56/ For some reason, the php56 cannot be found. I've also tried other ...

Install obsoleting package without removing obsoleted package

Is there any way to install an obsoleting package alongside the package it obsoletes using yum? There are a couple conflicting files but the packages can coexist just fine with the latest version of ...

Unable to install some required packages in Red Hat Linux

I Have RHEL6.5. I mam trying to install some required packages.Here is the response Error Downloading Packages: glibc-2.12-1.132.el6.i686: failure: Packages/glibc-2.12-1.132.el6.i686.rpm from Local:...

Centos- how to run yum with the proxy?

I come from Iran, where all Oracle products are forbidden to use and download because of US sanctions against us. I need to install MySQL on my centos server (that is in Iran) but i can't install ...

Downgrade Centos 7.2 to 7.1 [duplicate]

First of all, i understand that this is not a recommended approach to downgrade centos 7.2 to 7.1, the best course of action is to reload the system. However, due to some reasons, i cann't reload ...

Installing CentOS packages on fedora from repository

Is there a way to install CentOS packages on Fedora through yum (dnf) repository? I'm trying to install freeswitch, but their own repository only provides builds for RHEL and CentOS. I assume CentOS ...

CentOS 7/CloudLinux yum: Mass of Packages Can't Update

I run yum update and it tells me A LOT of packages need updating. I can't even fit it all into this post. These are the errors I get near the end... ---> Package python-magic.noarch 0:5.11-33.el7 ...

Dependency conflict when updating Yum in CentOS 7

On a newly installed CentOS 7 operatind system i am having this error while trying to run yum update Processing Conflict: kernel-3.10.0-514.6.1.el7.x86_64 conflicts kmod < 20-9 --> Finished ...
Translating... 0%