Newest epel Questions

Q&A for system and network administrators

centos: using epel repository on a server machine

Are there any downsides in enabling epel repository on a server machine or is it something every sysadmin does?

Requirementes on rpmbuild

I'm building a RPM package and one of my requirements is python-pip, only available in Epel repositories. (following line), Requires: python python-pip python-devel If the OS already has epel-...

CentOS EPEL install, bitness-independent command

I'm writing a small 'install script' and it requires EPEL on CentOS. The command (repo url) differs according to OS bitness, how do I unify this into one command? References: How to install EPEL I ...

Instal ejabberd on centos 6.7 - epel is enabled still No package ejabberd available

I am trying to install ejabberd on my centos 6.7. As I googled I found that I need to enable EPEL which I did still there is no success. Out put for yum repolist [root@static ~]# yum repolist Failed ...

YUM Update Error

I am receiving the following errors when running yum update. I began receiving these errors after I had installed the incorrect EPEL package (epel-release-6-8.noarch). I have since removed and ...

opendkim requires libcrypto [duplicate]

I am trying to install opendkim. For that, I used rpm to install epel, then did yum install opendkim. However, I get the following dependency errors: Error: Package: opendkim-2.9.0-2.el6.x86_64 (epel)...

Is it safe to use the EPEL repository on CentOS systems? [duplicate]

I recently submitted a Puppet patch which would have enabled the EPEL repository on a number of our CentOS 7 systems (I need this in order to install Python 3). One of the sysadmins rejected the ...

Installing from EPEL on Amazon EC2

I am trying to install fail2ban on our Amazon EC2 Linux AMI (CentOS). I know that fail2ban is in the EPEL so I have done the following: wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-...

Installing lighttpd on CentOS 6.3 yum 404 errors

I have a CentOS 6.3 x86_64 server and I am trying to install lighttpd. I have installed the EPEL repo on the server using the following: rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-...

Installing Redis on CentOS 6.6 final - no package available

I've added the "EPEL" repo: Loaded plugins: changelog, downloadonly, fastestmirror, presto Loading mirror speeds from cached hostfile * elrepo: repos.mia.lax-noc.com * epel: epel.gtdinternet.com * ...

why yum could not find the python-pip packages on some PCs

I got a very strange problem and cannot figure out why. When I run yum info python-pip command on some CentOS 7 machines, it returns Error: No matching Packages to list. But, I used to install python-...

Installing HAProxy on CentOS 6.3?

This is a weird one. I've installed the EPEL for CentOS 6 via # rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm The tried to install HAProxy: # yum update # yum ...

Lighttpd ldap auth issue, massive performance loss (lighttpd 1.4.35-1.el6.x86_64 + RHEL 6.6)

I installed lighttpd for the first time from epel repo. I changed user and group for the webserver and ran the lighttpd server. I can download a page with 200 small images in about a second. If I ...

Centos: Clamd and Razor-agents dependency failure on yum update when EPEL is enabled

I want to install Gitlab 6 to my CentOS 6.4 x64 server. I'm following the tutorial and enable EPEL with this command: rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch....

How to handle Puppet version differences between linux distributions

We're a small webdev shop that's investigating to roll out Puppet on various development and production servers. The puppetmaster is an Ubuntu 10.04 server with Puppet 0.25.4, from Ubuntu's repo. ...

how to choose the correct repository for new software on Centos

I want to install PHP7 and on Centos you can only do that by installing extra repositories. I see a variety of them (remi, ius, webtatic), and the comments on forums are both pro and contra. I am ...

I think I've resolved dependency, rpm doesn't

I have upgraded EPEL repo in order to install Remi repository in order to upgrade PHP to 3.5.4 in order to upgrade civicrm (on a CentOS 6.7 VPS running one production site and its dev site). repolist:...

phpmyadmin vs EPEL

I am running Centos 6.0 (Final) , the i386 version. I am trying my hardest to get a decent LAMP Server running, with phpMyAdmin. I can get everything installed just fine, MySQL, Apache2 (httpd), PHP ...

EPEL Repo GPG Key Working?

I followed the below steps to grab the EPEL GPG key and I'm trying to verify if it's working. This is on a freshly installed RHEL7 system. Repo: https://dl.fedoraproject.org/pub/epel/7/x86_64/ # cd /...

install php-mcrypt Centos 6

I'm trying for a few days now to install php-mcrypt on Centos 6 64bit, but I get this error [root@cimpan tmp]# yum install php-mcrypt Loaded plugins: fastestmirror Loading mirror speeds from cached ...

How to install rpm package from pbone.net?

I need to install ansible-2.1.0.0-1.el7. It was always in the epel repo and it was the latest release I just had to do: yum -y --enablerepo=epel install ansible It was all fine. But now the this ...

Install PEAR Mail/Mime Dependency issues in pure EPEL installation

Newbie in the sysadm area. Using Centos 6.2. I am trying to install PEAR's Mime.php. I have successfully installed PEAR's Mail before. It's not going to well now for Mime.php. This is what I do: ...

Selinux blocks wordpress in CentOS 6.3

I installed wordpress 3.5 to CentOS 6.3 using command: yum install wordpress and started httpd. Now I can see the following error in apache log: PHP Fatal error: require_once(): Failed opening ...

monit not able to monitor mysql with sock

Just in case if you are using Monit version 5.1.1 and try to monitor mysql with sock it will always fail with "Connection failed" my monit configuration file is: check process mysql with pidfile /...

fedora packages for enterprise linux

There are a number of packages available on fedora that I would like to install on RHEL v6.x. These packages do not appear to be available from RHEL (release, release-optional, or supplementary ...

transitioning packages to EPEL version

I have previously installed backuppc 3.1.0 from centos 5 testing. The package is now not maintaned by centos anymore. EPEL have BackupPC version 3.3.0, but yum check-update did not suggest that this ...

Verification of downloaded package with rpm

I wanted to install a package on CentOS 6 via rpm (e.g., the current epel-release). EDIT: Of course I would always prefer the installation via yum but somehow I failed to get that specific package ...

EPEL broken package : How do I reach to EPEL maintainer?

.. it looks like at least two of packages that comes from EPEL is broken: [alexus@wcmisdlin02 ~]$ sudo yum update --skip-broken Loaded plugins: refresh-packagekit, security Setting up Update Process ...

centos 6 epel alternative repository replacement

I've installed EPEL repository already on my server. I wanted to install something new and I get this error with yum : PYCURL ERROR 22 - "The requested URL returned error: 403 Forbidden" Trying ...

Missing `fastcgi_cache_purge` from Centos 7 EPEL `yum install nginx`

I installed nginx on Centos 7.1 with yum install nginx (from the EPEL repos). I am setting up WordPress caching as per https://codex.wordpress.org/Nginx and getting unknown directive "...

When should one use EPEL 5 or EPEL 6?

I am not familiar with repos, and I don't get why there are several versions of EPEL (this is a bit philosophical I know, but I am afraid I am missing something in all that). Should I just look ...

CentOS repositories: EPEL or rpmforge, which one is better and why?

So everyone who uses CentOS knows the default repositories have their limits. I've been using rpmforge for years as a secondary repo. I usually use yum priorities to make sure rpmforge never installs ...

could not find recipe epel for cookbook yum

i am having trouble with nginx cookbook.. and it dependency on yum-epel. Getting error : " Chef::Exceptions::RecipeNotFound could not find recipe epel for cookbook yum" $ knife cookbook show ...

install php-mcrypt on Centos 6

I'm trying to install php-mcrypt on my Centos 6.0, 64 bit, php 5.3.3. I'm using epel repo rpm -Uvh http://download.fedora.redhat.com/pub/epel/6/x86_64/epel-release-6-5.noarch.rpm, the last one. But ...

Centos 7, python-virtualenvwrapper, EPEL and profile.d

I installed virtualenvwrapper via yum/epel and discovered that it causes su to throw errors. Investigation shows that the yum install puts a symlink for /usr/bin/virtualenvwrapper.sh into /etc/...

EPEL & RPM Fusion for Servers?

Has anyone found EPEL & RPM Fusion to be stable enough for production servers? Currently running CentOS

How can I install git on RHEL 6?

I'm trying to install Git on a RHEL6 development server, I have experience with Ubuntu but this is my first time working with RHEL (I'm a developer trying to fill in for a recently departed Linux ...

Certificate error with EPEL repository on CentOS6.7 using mirrors.fedoraproject.org

Can't update a CentOS 6.7 system with the EPEL repository configured. [epel] name=Extra Packages for Enterprise Linux 6 - $basearch mirrorlist=https://mirrors.fedoraproject.org/mirrorlist?repo=epel-6&...

Enable the EPEL repository on AWS Elastic Beanstalk

I need to install some tools from the Extra Packages for Enterprise Linux repository (EPEL) that are not available in the default repositories of the Amazon Linux AMI. /etc/yum.repos.d/epel.repo ...

Update power dns from EPEL repo

I'm using EPEL repo on Centos 6. If I start update for power dns with mysql backend - so please - must I update mysql schema manually, or YUM will do this self? Thank youů

Broken dependencies on CentOS 6.4: can install nodejs but not npm

I'm using a fresh installed CentOS 6.4 (x86-64) with the EPEL repository. $ yum install nodejs ... $ node -v v0.10.5 So far, so good, but when I try to install npm, I'll get this error message: $ ...

Centos 6, Plesk 11, EPEL 6 install problems

I'm having a real headache configuring a new server. It's a 64bit Linux box with Centos 6 and Plesk 11. This will be a Magento server, so I need mcrypt installed, which isn't available by default. ...

Which EPEL release do I need?

I have a 64 bit server machine with: Oracle Linux Server release 6.5 Red Hat Enterprise Linux Server release 6.5 (Santiago) and I need to install EPEL repository. I've already tried few of them: ...

EPEL Repo for CentOS 6 causing error

I've got a VM running CentOS 6 (64bit) and I'm attempting to add the EPEL repo like usual to install various packages as I do quite regularly. Today, I'm experiencing some strange errors yet I'm ...

While trying to enable epel I somehow broke my repolist

I originally posted this on stack overflow and was told this was the better place to ask: I made the attempt at enabling EPEL on my Fedora 22 machine by running wget http://dl.fedoraproject.org/pub/...

Updating epel repo to 6 - epel-release-6-x.noarch conflicts with file from package epel-release-5-x.noarch

I am following an epel repo upgrade guide from Centos 5 to Centos 6 here (http://www.thegeekstuff.com/2012/06/enable-epel-repository/ and http://www.linuxquestions.org/questions/linux-server-73/epel-...

Can't get yum repository (ius) to install because of (epel) dependency that seems to be installed

So I'm trying to install the epel repository and then also install the ius repository. I'm managing this server with chef, and my run list goes ... "recipe[yum::yum]", "recipe[yum::epel]", "recipe[...

Difference between libcrypto.so.10()(64bit) and libcrypto.so.10(libcrypto.so.10)(64bit) dependencies

We are seeing an error updating our yum packages on several servers. Several nagios packages are complaining that libcrypto.so.10(libcrypto.so.10)(64bit) is not available. We have openssl installed ...

Upgrade R to 3.1.1 on ec2 via yum

I have an ec2 instance with an older version (3.0.2) of R that I'm trying to update to the latest (3.1.1). This is not available in the default yum repo, but is available under EPEL. The installed ...

Exclude a specific repo from YUM Update

I am doing a system wide yum update on RHEL 5.5 and the IUS EPEL repository is throwing a missing dependency error: php53-mcrypt-5.3.3-4.ius.el5.x86_64 from installed has depsolving problems --> ...
Translating... 0%